Manuel Workey Designer - Guide du concepteur : fonctions simples

Dernière mise à jour le 07/03/2014

La modélisation selon la méthode OSSAD

Sommaire

Préambule

Ce chapitre présente les fonctionnalités dites simples de Workey Designer. Elles sont les plus couramment utilisées pour la modélisation de processus d'entreprise. L'ensemble des fonctions OSSAD est présenté dans ce chapitre.

La section des fonctions avancées aborde les fonctions complémentaires de Workey Designer notamment quand le concepteur a pour objectif d'automatiser le processus modélisé. Pour appréhender cette section, il est indispensable de disposer de la suite complète de BPM Workey à savoir:

  • Workey Designer - version Online
  • Workey Engine et sa licence d'utilisation

Les modèles suivants ne sont pas abordés dans ce chapitre:

  • la création de formulaire
  • la création de règles du dictionnaire
  • la création de vues utilisateurs


Créer un projet

Après avoir lancé une session de travail, sélectionnez l'option Nouveau/Projet dans le menu Fichier.


Un nouveau projet "Sans Nom" est automatiquement créé.


Dans la partie gauche de la fenêtre apparaissent les dix types de graphes qu'il est possible de construire avec Workey. Sept types de modèles sont issus de la méthode OSSAD. 
Le modèle de règles, le modéle de formulaire et le modèle de vues utilisateurs sont principalement utilisés dans une logique d'automatisation du processus.

Image:Graphes.jpg

  • les graphes de Modèles abstraits: enchaînement de fonctions, fonctions externes et paquets d'information,
  • les graphes de Processus: enchaînement des procédures,
  • les graphes de Procédures: enchainement des opérations,
  • les graphes d'Opérations: la description du déroulement d'une procédure,
  • les graphes de Formulaires: modèles décrivant la structure des formulaires,
  • les graphes de Matrices A/R: matrice présentant les relations entre les rôles d'une procédure et les fonctions du modèle abstrait,
  • les graphes d'Organigrammes: représentation des unités organisationnelles,
  • les graphes des Règles du dictionnaire: graphes permettant de définir des règles d'entreprise dans la gestion des actions,
  • les graphes de Modèles de rôles: modèles décrivant la structure des rôles agissant sur les processus,
  • les graphes Vues utilisateur: modèles de représentation des vues sur les documents des processus.
Dans la partie droite de la fenêtre apparaissent l'onglet des différents objets que l'on peut utiliser
sur le graphe sélectionné ainsi que l'onglet des propriétés de l'objet sélectionné.


Il suffit de sélectionner l'un des types de graphes pour afficher les propriétés permettant de le définir.

  • Libellé: Permet de saisir un titre visible pour le projet
  • Nom interne: Nom unique de l'objet workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes est respectée.
  • Créé le: Date de création du projet
  • Créé par: le nom de l'utilisateur qui a créé le projet
  • Modifié le: Date de dernière modification du projet
  • Modifié par: Nom de l'utilisateur qui a effectué la dernière modification sur le projet
  • Description: Permet de saisir un texte de description du projet
  • Étendue: Permet de lier un fichier externe contenant une description personnalisée
  • Aide: Permet d'entrer un texte d'aide



Rappel sur la méthode OSSAD

 Ossad résulte d’un projet de recherche européen mené de 1985 à 1989 dans le cadre du programme ESPRIT. Cette méthode ouverte et non-propriétaire a pour but de gérer les problèmes organisationnels amenés par l’arrivée massive de la technologie dans les bureaux (bureautique). OSSAD préconise une modélisation de l’organisme étudié. Les modèles élaborés utilisent un formalisme graphique et servent de référence à la réflexion commune des participants, tant pour décrire l’existant que pour imaginer les solutions futures.

 

Ossad n'impose pas d'ordre particulier dans l'élaboration de ses modèles. Cette approche prône au contraire un cheminement non linéaire et guidé de manière très pragmatique par les intervenants du projet. Avec Ossad, il est parfaitement concevable de commencer par le particulier pour "remonter" ensuite au général, puis de procéder à des allers et retours autant de fois qu'il est nécessaire. A des démarches "top-down" ou "bottom-up", Ossad préfère une démarche "up and down" ou "yo-yo", le lien nécessaire entre les deux niveaux de modélisation abstrait et descriptif étant fait par des matrices activités-rôles.

 Image:Ma.jpg

OSSAD propose deux niveaux de réflexion: l’abstrait et le descriptif.

 

·         Le modèle abstrait permet d’exprimer les objectifs d’une organisation et la représente en termes de fonctions (par exemple marketing, finance, production) et de paquets d’information qui circulent entre ces fonctions (par exemple statistiques, contrats). Les fonctions peuvent se décomposer en autant de sous-fonctions que nécessaire pour représenter une organisation, et les fonctions non décomposées sont appelées activités.

 

·         Le modèle descriptif décrit les moyens humains et les ressources technologiques d’une organisation. Il la représente en termes de procédures (manière de réaliser une activité) et des différentes opérations nécessaires à leur accomplissement, ainsi qu’en termes de rôles (qui participe à quelle activité), d’outils et de ressources. Il se compose de trois types de formalismes graphiques: les matrices activités-rôles, les graphes de circulation des informations qui décrivent la communication entre rôles (graphe de rôles) et entre procédures (graphe de procédures), ainsi que les graphes des opérations d’une procédure.

 

En synthèse OSSAD se résume par ce schéma qui présente l’articulation des différents modèles et leur sémantique associée.

 Image:Enchainement.jpg

 

Modèle Abstrait

Le modèle abstrait de la méthode OSSAD s’intéresse aux objectifs d’une organisation, indépendamment des moyens et des ressources mis en œuvre pour les réaliser. Il offre plusieurs niveaux de visualisation en permettant de décomposer un processus en sous-processus et en activités. Il est donc relativement invariant et permet de représenter à un niveau conceptuel les processus d’une organisation, son environnement, et les paquets d’information qui circulent


Un modèle abstrait est donc un ensemble de graphes élaborés pour répondre à une question donnée ou un objectif. L'adjectif "abstrait" signifie qu'il a été fait abstraction des moyens mis en oeuvre pour se concentrer uniquement sur les objectifs à atteindre.

Si le modèle de procédures répond à "Qui, Comment, Quand", le modèle abstrait répond à "Quoi et Pourquoi".


Double cliquez sur Modèles abstraits dans le panneau des projets pour créer un nouveau graphe.

Général
  • Libellé: Permet de saisir un titre visible dans la génération de la documentation pour le graphe
  • Nom interne: Nom unique de l'objet workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes des objets est respectée.
    Décochez cette option pour personnaliser le nom interne.


Description: Permet de saisir un texte de description, lier un fichier externe contenant une description personnalisée et entrer un texte d'aide.


Liens: Il est possible d'ajouter des liens logiques aux objets Modèle abstrait.

Exemple de modèle:


Construction


Image:Abstraitcomps.jpg

Trois composants sont disponibles pour construire ce type de graphe:

Fonction: Une fonction est un sous-ensemble d’une organisation qui poursuit des objectifs homogènes. L’organisation est ainsi représentée par le Modèle abstrait. Une fonction peut être décomposée en sous-fonction.

Fonction externe: Une Fonction externe (ou processus externe) n’appartient pas à l’organisation étudiée mais fait partie de son environnement. Une Fonction externe est représentée dans un Modèle abstrait pour illustrer la circulation des Paquets d’information entre une organisation et son environnement, mais elle ne peut pas faire l’objet d’une décomposition.

Paquet d'information: UnPaquet d'informations représente un ensemble d’informations circulant entre Processus (et/ou des Entités externes). Il s’agit de l’unique lien possible entre ces derniers et il doit être émis par un et un seul Processus. Il peut par contre être reçu par plusieurs Processus (au minimum un), y compris par son émetteur.

Seuls des liens standards peuvent être utilisés.

On peut ajouter autant d'Annotations que l'on veut pour plus de clarté ou d'organisation.


Fonction
Une Fonction est un sous-ensemble de l’organisme fournissant un certain résultat, ou un ensemble d’actions ayant un même objectif, indépendamment des moyens concrets utilisés pour les effectuer. La Fonction correspond à un premier niveau de découpage de l’organisme.
Général
  • Libellé: Permet de saisir un titre visible dans la génération de la documentation pour l'objet
  • Nom interne: Nom unique de l'objet workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes des objets est respectée. Décochez cette option pour personnaliser le nom interne.


Description: Permet de saisir un texte de description, lier un fichier externe contenant une description personnalisée et entrer un texte d'aide.


Liens: Il est possible d'ajouter des liens logiques aux objets Fonction.


Décomposition: Une fonction peut être décomposée en sous-fonction. Pour cela maintenez la touche [Ctrl] appuyée et double cliquez sur l'objet fonction de votre graphe. Un nouveau diagramme est affiché à l'écran.


Fonction externe
Entité externe à l'organisme étudié, faisant partie de son environnement et poursuivant des objectifs homogènes.
Général: Permet de définir le libellé et le nom interne de l'objet.


Description: Permet de saisir un texte de description, lier un fichier externe contenant une description personnalisée et entrer un texte d'aide.


Liens: Il est possible d'ajouter des liens logiques aux objets Fonction externe.

Par définition, une fonction externe ne fait pas l'objet d'un zoom . Elle est généralement hors de portée de la réorganisation qui fait l'objet du projet ossadien.


Paquet d'informations
Ensemble d'informations circulant entre les fonctions et/ou les fonctions externes.

Un paquet n'a pas forcément de support tangible. Comme le nom de ce concept l'indique, il peut représenter une certaine agrégation de supports d'information.

Général: Permet de définir le libellé et nom interne de l'objet.


Description: Permet de saisir un texte de description, lier un fichier externe contenant une description personnalisée et entrer un texte d'aide.


Liens: Il est possible d'ajouter des liens logiques aux objets Paquet d'informations.

Un paquet est émis par une et une seule fonction. Par contre, il peut alimenter une ou plusieurs fonctions, y compris la fonction émettrice. Les paquets sont donc liés aux fonctions par des arcs, représentés par des flèches unidirectionnelles.


Dans un modèle abstrait finalisé, il n'existe pas de paquet "orphelin", c'est-à-dire de paquet émis par aucune fonction ou fonction externe. De même, un paquet doit au moins aboutir à une fonction ou fonction externe. L'unique lien possible entre les fonctions est le paquet d'informations.


Construction d'un Zoom sur une fonction

Une fonction peut être zoomée en sous fonctions. Pour cela maintenez la touche [Ctrl] et double cliquez sur la fonction dans le graphe afin que Workey Designer crée directement le graphe Zoom. Il est également possible de créer le graphe zoom en pressant le bouton adécquat dans la barre de bouton 

Automatiquement Workey designer, recopie l'ensemble des données d'entrée et de sortie dans le graphe zoom.

Placer dans la zone grisée les sous-fonctions;

Placer à l'extérieur de la zone grisée des fonctions externes si besoin.

Il est possible de décomposer une fonction, en N niveaux. Une fonction feuille sera nommée activité. Cette activité pouvant être alors attachée à une procédure. Ce sont ces activités que l'on retrouvera dans la Matrice Activité/Rôle.

Image:Ma niv2.jpg

Modèle de Processus

Processus
Ensemble d'activités corrélées ou interactives qui transforme des éléments d'entrée en éléments de sortie.

Double-cliquez sur Processusdans le panneau situé à gauche pour créer un nouveau graphe.

Propriétés

  • Libellé: Permet de saisir un titre visible pour le projet
  • Nom interne: Nom unique de l'objet Workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes est respectée.
  • Description: Permet de saisir un texte de description du projet
  • Étendue: Permet de lier un fichier externe contenant une description personnalisée
  • Aide&: Permet d'entrer un texte d'aide
  • Indicateur de Performance: Permet de spécifier sous forme texte un indicateur concernant la mesure du processus.
  • Objectifs: Permet d'entrer un texte de description des objectifs à atteindre grâce au processus

Dans l'onglet Composants, retrouvez les objets que vous allez pouvoir utiliser

dans le graphe du Processus.


4 composants sont disponibles: Document, Procédure, Ressource et Entité Externe.


Cliquez sur un objet et faites-le glisser dans la fenêtre du processus,

puis déposez-le où vous voulez le placer.

Exemple de processus:

Entité Externe

Une est un objet purement descriptif qui apporte plus de clarté à un graphe de processus en ouvrant des possibilités pour plus de description.

  • Libellé: Permet de saisir un titre visible pour le projet
  • Nom interne: Nom unique de l'objet Workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes est respectée.
  • Description: Permet de saisir un texte de description du projet
  • Étendue: Permet de lier un fichier externe contenant une description personnalisée
  • Aide: Permet d'entrer un texte d'aide
  • Liens : Permet d'ajouter des liens logiques.


Modèle de Procédures

Procédure

Regroupement pertinent de Tâches permettant d’avoir une vue d’ensemble du travail sur une Activité.

C’est un ensemble de Tâches (ou d’opérations) composant une Activité. La Procédure est l’aspect descriptif d’une Activité, une façon de la mener à bien. C’est aussi une représentation dynamique (le temps intervient) du travail d’un bureau sous forme d’un enchaînement de Tâches ou d’opérations regroupées en Tâches. Une Procédure met en cause un ou plusieurs Rôles.
Elle permet d’avoir une vue d’ensemble sur les Tâches effectuées à l’intérieur d’une même Activité. Une Procédure a des intrants et des extrants bien définis et l’on peut associer à ces derniers des critères d’évaluation. Il s’agit de ceux qui concernent l'efficience ou productivité (rapport entre les intrants et les extrants). L’efficacité des extrants est plutôt rattachée aux Activités (par leurs objectifs).

Un graphe de procédures permet de représenter la circulation de ressources en informations entre les procédures.


Pour créer une nouvelle procédure vous pouvez soit:

- créer une procédure à partir d'un graphe de type "procédure"

- Zoomer l'objet "procédure" qui se trouve au sein d'un graphe de type "processus"


Création d'une procédure depuis un graphe de type "procédure"

  1. Double-cliquez sur Procédures dans le panneau de gauche pour créer un nouveau graphe de procédure


Création d'une procédure depuis un graphe de type "processus"

  1. Dans l'onglet des Composants, glissez-déposez un objet Procédure dans le processus .
    Sélectionnez la procédure désirée et double cliquez dessus en maintenant la touche [Ctrl] du clavier appuyée. Puis relâchez la touche [Ctrl]. Cela crèe un Graphe Zoom de la Procédure et l'ouvre.


Propriétés

  • Libellé: Permet de saisir un titre visible pour le projet
  • Nom interne: Nom unique de l'objet Workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes est respectée.
  • Description: Permet de saisir un texte de description du projet
  • Étendue: Permet de lier un fichier externe contenant une description personnalisée
  • Aide: Permet d'entrer un texte d'aide.
  • Indicateur de Performance: Permet de spécifier sous forme texte un indicateur concernant la mesure de la procédure.
  • Objectifs: Permet d'entrer un texte de description des objectifs à atteindre grâce au processus.


Liens

Liaisons, liens, relations

Les rapports entre entités ou concepts des modèles ossadiques sont nommés « liaisons ».
Les liaisons entre entités de différents niveaux d’une structure arborescente (par exemple Fonction, Sous-fonction, Activité) sont nommés « liens ».
Les liaisons entre entités de même niveau (par exemple entre Activités) sont nommées « relations » (sous-entendu horizontales ou latérales).

Les liens sont donc des liaisons de type vertical soit ascendantes, soit descendantes (sous-entendu dans les niveaux de l’arborescence).


Dans un graphe de type "procédure", il s'agit de lier entre eux documents et opérations (ou conditions) pour indiquer la séquence d'exécution de la procédure.

Workey Designer vous propose quatre types de liens pouvant être utilisés dans une procédure.
Image:Liens.jpg


Standards


Les liens de déclenchement (standard): en noir avec une simple flèche.

Ils peuvent relier un document/état avec une opération (ou condition) et signifient que l'opération porte sur le document/état (en général pour modifier l'état du document). Ils peuvent également relier une opération (ou condition) avec un document/état et signifient alors que l'opération produit un (changement d'état du) document.

Image:Standard.jpg

Un lien standard est porteur de propriétés; Ces propriétés sont présentées ci-après:

Sélection

  • Acteurs
    • Aucun acteur: les acteurs suivants sont tous les acteurs de la liste des candidats
    • Un acteur: obligation de choisir un et un seul acteur dans la liste des candidats
    • Plusieurs acteurs: possibilité de choisir un nombre quelconque d'acteurs dans la liste des candidats. En cas de non-sélection, la liste de candidats toute entière est retenue. Vous pouvez préciser un nombre minimum ainsi qu'un nombre maximum d'acteurs.
    • Groupe de travail: possibilité de choisir un nombre quelconque d'acteurs dans la liste des candidats pour définir un groupe de travail autour du document concerné (tous les acteurs du groupe devront avoir "fait suivre" le document pour que le document passe à l'étape suivante). Vous pouvez préciser un nombre minimum ainsi qu'un nombre maximum d'acteurs.
  • Afficher les unités: définit que la sélection d'acteur porte sur des unités organisationnelles.


Notification

  • Acteur
    • Acteurs suivants: tous les acteurs potentiels suivants recevront un courriel les informant qu’ils ont une action à mener.
      • Automatiquement: permet de rendre automatique l’envoi d’un courriel; si cette option  n’est pas choisie, l’utilisateur  pourra décider lui-même de l'envoi ou non de ce courriel à la soumission du formulaire.
    • Acteur précédent: un courriel d’information sera envoyé automatiquement à l’acteur ayant réalisé l’opération précédente
    • Acteurs intermédiaires: un courriel d’information sera envoyé automatiquement aux acteurs ayant réalisé une opération sur le document depuis sa création.
    • Auteur du document: un courriel d’information sera envoyé automatiquement à l’acteur ayant créé le document
    • Superviseurs: un courriel d’information sera envoyé automatiquement aux acteurs étant définis comme Superviseur du processus
    • Utilisateurs du champ: un courriel d’information sera envoyé automatiquement aux acteurs étant renseignés un la valeur du champ spécifié. On notera que ce champ peut être multi-valué (contenir plusieurs noms d'utilisateurs).
  • Mode
    • Par messagerie: permet l'envoi d'une notification par email.
    • Par alerte: permet l'envoi d'une notification par message pop-up sur le poste de l'acteur concerné (sous réserve d'installation du module de notification Workey sur le poste de l'acteur concerné ).


Options

  • Condition: Permet d'insérer une règle Stalk de contrôle de la validité de la transaction. Selon que l'instruction retourne vrai ou faux, le document pourra ou non changer d'état. Image:Conditionicons.jpg
    • Nouveau: permer de créer une nouvelle règle.
    • Sélectionner: permet de sélectionner une règle existante.
    • Accèder: permet d'accèder à la règle sélectionnée.
    • Supprimer: permet de supprimer la sélection courante (pas la règle) afin d'en choisir une autre.
  • Priorité: permet de définir un ordre de priorité des liens en sortie d'une opération.


Connecteur

Liste les connecteurs disponibles pour le document porté par le lien.
Les flèches haut et bas permettent de faire monter ou descendre un connecteur dans la liste. Les connecteurs seront traités par ordre de priorité comme ils apparaissent dans la liste.

  • Actif: active ou désactive l'exécution d'un connecteur.
  • Connecteur: nom du connecteur.
  • Fatale: active ou désactive l'arrêt de l'exécution sur erreur fatale.


Image:Standardprops.jpg



Description: Permet de saisir un texte de description

  • Étendue: Permet de lier un fichier externe contenant une description personnalisée
  • Aide: Permet d'entrer un texte d'aide


Liens: Il est possible de définir des liens logiques pour les objets Lien standard.


Synchronisation

Les liens de synchronisation: en rouge avec une flèche simple. Ils relient les documents avec les pré-conditions de type ET.

Ils signifient que l'opération n'est possible sur ce document dans cet état précis que si le document synchronisé (flèche rouge) a atteint (au moins une fois en cas de cycle) l'état spécifié.

Image:Synchronisation.jpg


Il est possible d'entrer un texte de description sur ce type de lien, de lier une description étendue ou d'ajouter des liens logiques.


La synchronisation est le rappel des documents fils vers le document père.

Lorsque les fiches d'actions sont arrivée en fin de vie à l'état validée, l'action peut avoir lieu.


Image:Synchroprops.jpg


Afin de contrôler que touts les facteurs influant sur le cours de la vie des documents sont bien favorables, nous devons installer une pré-condition ET qui sera exécutée en entrée de l'opération de synchronisation.

  • Le document Incident est dans l'état planifié
  • Le ou les documents
    Fiche d'actions sont dans l'état validée
Si l'une des instructions est fausse, la synchronisation ne pourra pas avoir lieu et les documents ne changeront pas d'état.

Si les deux instructions sont vraies, alors le Responsable support pourra exécuter l'opération clôturer et le document Incident, contenant les données des fiches d'actions plus les siennes passera à l'état clôturé.


Workey Designer crée la pré-condition ET automatiquement pour permettre à la synchronisation d'avoir lieu lorsque vous placez un lien de type synchronisation.


Exemple: La procédure Traitement des actions
Procédure Traitement des actions

Dérivation

Une dérivation de document est l'action de créer un ou plusieurs "sous-documents" appelés documents dérivés ou documents fils qui seront liés au document principal mais qui suivront leur propre cycle de vie indépendamment du document père.

Il est possible de créer une multitude de documents fils mais un document fils ne peut avoir qu'un seul père.


Workey Designer permet d'implémenter une dérivation de plusieurs façons, grâce à:

  • une vue embarquée dans un formulaire
  • une opération automatique ou manuelle
  • une classe Java (outil connecteur)


Les liens de Dérivation sont bleus avec une flèche simple. Ils relient les documents avec une post-condition de type ET.

Ils signifient qu'un ou plusieurs nouveaux documents dérivés ou documents fils sont créés et liés au document courant.

Image:Liendérivation.jpg


Les sections Sélection, Notification, Options, Description et Lien sont disponibles et contiennent les même éléments d'option que pour les liens standards.


Délai

Les liens de Délai: en vert discontinu avec une flèche simple.

Ils servent à définir un dépassement de délais sur une opération.

Image:Liendélais.jpg


Général

  • Prochain état: rappel le prochain état qu'atteindra le document.
  • en: permet de spécifier une unité de temps en Jours ou en Heures pour l'exécution de l'agent des délais
  • Date: permet de spécifier une durée en jours avant exécution de l'agent.
  • Date de début: Spécifie quand l'agent devra s'exécuter
    • A la dernière opération: définit la dernière opération prévue dans le processus comme date butoir.
    • A l'atteinte de l'état: définit que la date de passage du document à un état donné sera la date butoir.
  • A une date spécifique: permet de sélectionner un champ de date qui contiendra la date butoir.
    • Lister seulement les champs date: permet de filtrer le contenu du champ de date spécifique.
  • Avertissements En Jour(s): permet d'installer trois paliers d’avertissements en spécifiant le nombre de jour avant l'arrivée de la date pour chacun des paliers.


Il aussi est possible d'ajouter un texte de description pour ce type de lien, lier une description étendue ou ajouter des liens logiques.


Il est possible de lier un état de document en Entrée de plusieurs opérations ou plusieurs états de document

en Entrée d'une opération.

Il est possible de lier une opération à plusieurs états de documents ou un état de document en Sortie de plusieurs opérations.

Un lien créé entre deux objets ne peut pas être déplacé vers un autre objet. Il faut alors le supprimer et en créer un nouveau.

Les liens créés à partir d'une post-condition portent une légende qu'il est possible de saisir pour expliciter les critères du choix. Cette légende figure dans les propriétés du lien uniquement à titre indicatif et n'est pas interprétée lors de la génération.


Tous les objets ne sont pas liables entre eux, si vous essayez de lier deux documents entre eux par exemple aucun lien ne sera créé. (voir rubrique "Vérification de cohérence" pour plus de précisions).

Pour supprimer un lien, il suffit de le sélectionner avec la souris, puis d'appuyer sur la touche [Suppr] du clavier ou sur le bouton "Supprmimer" de la barre d'outils

.

Les liens sont créés avec des points d'attache sur les objets. Il est possible de modifier ces points d'attache par drag&drop à partir du point d'attache. Image:Attache.jpg
Si vous désirez insérer un point d'encrage pour faire varier l’esthétique du lien, cliquez sur le lien pour le sélectionner, puis faites glisser la souris vers l'endroit où vous désirez que le lien se courbe.

Pour supprimer un point d'encrage, sélectionnez-le avec la souris (faites un sélection entourant le point d'encrage) et appuyez sur la touche [Suppr] du clavier.


Les liens créés à partir d'une post-condition portent une légende qu'il est possible de saisir pour expliciter les critères du choix. Cette légende figure uniquement à titre indicatif et n'est pas interprétée lors de la génération. On peut la déplacer avec un drag&drop avec le bouton droit de la souris.


Conditions

Image:Conditions.jpg

Workey permet de spécifier des fonctionnements plus sophistiqués à l'aide des post-conditions et des pré-conditions.

Post-conditions et pré-conditions sont des propriétés de l'opération.

Lors de leur création, les post-conditions sont de type OU (choix) ou ET et les pré-conditions de type ET (synchronisation) ou OU.

  • Lorsqu'une opération est munie d'une post-condition, les liens en sortie de l'opération sont rattachés à la post-condition.
  • Lorsqu'une opération est munie d'une pré-condition, les liens en entrée de l'opération sont rattachés à la pré-condition.


Pour rendre possible le cheminement du document vers un état ou un autre, il est nécessaire d'installer une condition car une transaction ne peut aboutir qu'à un seul état en sortie d'une opération.


Exemple :

Ici, deux post conditions OU sont installées en sortie des opérations traiter et qualifier.


Lorsque l'utilisateur exécute l'opération traiter, il à la possibilité de faire passer le document vers l'état escaladé à destination d'un autre acteur OU alors de le faire passer vers l'état clôturé.

Lorsque le deuxième acteur reçoit le document dans l'état escaladé, il a le choix en exécutant l'opération qualifier de faire passer le document vers l'état qualifié OU vers l'état clôturé.


Les différents fonctionnements que l'on peut spécifier avec les post-conditions et pré-conditions sont les suivants:

  • choix : l'utilisateur devra choisir entre plusieurs états possibles en sortie pour le document traité par l'opération. On parle de post-condition de type OU (pouvant comporter des règles d'autorisation, assorties éventuellement d'un mécanisme de sélection automatique),
  • déclenchement alternatif: plusieurs états du document traité lors de l'opération peuvent déclencher celle-ci. On parle de pré-condition de type OU,
  • dérivation : un document dit "principal" est modifié (son état change) au cours de l'opération et en parallèle, un nouveau document dit document dérivé est créé en reprenant une partie des informations communes contenues dans le document principal. On parle de post-condition de type ET,
  • synchronisation : le changement d'état du document traité par l'opération est conditionné par le fait qu'un autre document (dont il est soit document principal, soit document dérivé) ait atteint un certain état. On parle de pré-condition de type ET, accompagnées de liens de synchronisation,
  • opération parallèle: un document peut être traité en parallèle par plusieurs rôles.


Les différents objets graphiques d'une procédure 

Différents composants peuvent être ajoutés à une procédure.

Image:Procedurecomps.jpg

  • Rôle: Permet de créer un objet rôle
  • Document: Permet d'ajouter un objet Document en entrée ou en sortie d'une opération
  • Opération: Permet d'ajouter un objet Opération
  • Parallélisme: Permet d'ajouter un container qui accueillera plusieurs Opérations qui seront traitées en parallèle
  • Procédure: Permet de déclencher une sous procédure lorsqu'un document atteint un certain état
  • Ressource: Permet de décrire un flux de ressource
  • Outil: Permet de décrire l'utilisation d'un connecteur de champ, d'opération ou une procédure stoquée
  • Tâche programmée: Permet d'automatiser le traitement d'un événement lié aux données (cf fonctions avancées)
  • Vue embarquée: Permet de créer une vue pour l'utilisateur intégrée dans un formulaire (cf fonctions avancées)
  • Mémo: Permet de décrire un flux d'information (cf fonction avancées)


Pour ajouter un composant à une procédure, faites-le glisser dans le panneau central de composition du graphe avec la souris.

Chaque composant à ses propriétés spécifiques.


Documents

Dans l'onglet des Composants, sélectionnez un objet , puis faites-le glisser dans le graphe de procédure.


Lorsque vous créez un objet document, son état par défaut est toujours "Nouveau".
Il est possible de modifier l'état du document en sélectionnant un état existant dans la liste des états ou
en saisissant un nouveau nom.

Double-cliquez sur l'objet document pour en éditer les propriétés principales ou reportez-vous à l'onglet Propriétés de l'objet sélectionné.


  • Libellé: Permet de saisir un titre visible pour le document
  • Nom interne: Nom unique de l'objet Workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes est respectée.
  • Sujet: Permet de définir un sujet grâce à une phrase simple ou un script Stalk.
  • État: Permet de sélectionner ou saisir un état pour le document ainsi que d'entrer une description.
    • Modifier tous les états: Permet de répercuter la modification courante sur toutes les occurrences de l'objet dans le projet.


  • Formulaires: Permet d'affecter un ou plusieurs formulaires et d'ajuster leur visibilité.
  • Connecteurs: Permet d'attacher un connecteur d'opération au document qui sera exécuté à l'état défini.


  • Description: Permet de saisir un texte de description du projet
  • Étendue: Permet de lier un fichier externe contenant une description personnalisée
  • Aide: Permet d'entrer un texte d'aide
  • Liens: Il est possible de définir des liens logiques pour les objets de type document.


États des documents

Workey Designer dispose de quatre états systèmes qui sont sélectionnables lors de la création d'un document.
On peut créer ensuite une infinité de nouveaux états pour chaque document.

  • Détruit: Supprime le document courant du système d'information.
  • Nouveau: État par défaut lorsque l'on crèe un document - Crée un point d'entrée dans le flux de travail.
  • Publiable: Défini le document comme prêt à être publié via le portail WCM.
  • Tout état: Donne accès à tous les états de sortie possibles pour le document en cours.


Pour créer un état personnalisé, il suffit de le saisir dans les propriétés de l'objet document concerné.

L'ordre des états peut être défini dans les propriétés du lien sortant d'une opération vers un document.

La spécification des états n'est utilisée que pour l'ordre d'évaluation des formules de calculs.
Du plus petit (évalué en premier) au plus grand (évalué en dernier).


Rôles

Dans l'onglet composants, choisissez l'objet pour placer quatre rôles dans la procédure.


En saisissant le libellé d'un objet Rôle, le nom interne de l'objet est calculé automatiquement
en fonction de votre saisie.
Pour assigner à l'objet un nom interne personnalisé, décochez l'option "Nom int. calculé automatiquement".


Les colonnes (démarquées par des lignes verticales) sont automatiquement créées en même temps que les rôles. Toutes les opérations figurant dans une colonne sont automatiquement affectées au rôle de la colonne. Il est également possible de modifier la position des rôles en tête de colonne. La finalité de définir un rôle privé ou un rôle public est de limiter la visibilité du document.

  • dans le cas d’un rôle public, tous les acteurs du rôle pourront avoir accès au document, qu'ils aient ou non traité ce document,
  • dans le cas d’un rôle privé, seul les acteurs ayant effectué une opération en jouant ce rôle auront accès au document.

On notera que cette propriété sera commune à toutes les instances d’un rôle dans un même projet.

Général

  • Libellé : Permet de saisir un nom visible pour le rôle
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique)
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir
  • Type
    • Public: tous les acteurs du rôle pourront avoir accès au document, qu'ils aient ou non traité ce document
    • Privé: seul les acteurs ayant effectué une opération en jouant ce rôle auront accès au document
    • Agent: ce rôle est joué par un agent qui exécutera la ou les opérations qui lui sont assignées en utilisant les accès du rôle
      • Périodicité: Spécifie le type de fréquence d'exécution de l'agent en Heure, Jours ou Mois
  • Formulaire: Spécifie un formulaire spécifique présenté à l'acteur du rôle lorsqu'il accède au document


Description: Permet de saisir un texte de description pour le rôle, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux objets Rôle.


Rôles Génériques

Il est possible d'inclure dans la modélisation les rôles de Superviseur et de Gestionnaire de données.
Ces rôles natifs à l'application ont une fonction bien précise.

  • Superviseur: permet un accès au document en lecture seule. Le Superviseur peut tout voir mais rien modifier.
  • Gestionnaire de données: permet un accès au document en écriture.
    Le Gestionnaire de données peur modifier le contenu des champs présentés en écriture mais pas changer les états de documents.

Ces rôles sont particulièrement utiles lors de la création des vues personnalisées.


Opération

Dans l'onglet des Composants, choisissez l'objet pour ajouter à la procédure une opération pour chaque rôle.


Général

  • Libellé : Permet de saisir un nom visible pour l'opération
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique)
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir
  • Options
    • Annulable par l'utilisateur: Permet de donner la possibilité à l'utilisateur de revenir sur une opération exécutée, après avoir soumis le formulaire.
    • Optionnelle: Permet de rendre une opération réalisable sans qu'elle ne bloque le flux de travail si elle n'est pas exécutée.
    • Signature requise: Permet de demander une nouvelle authentification lors de la soumission d’une opération. Tant que l’utilisateur ne renseignera pas le bon mot de passe, Workey refusera la soumission du document.
  • Durée: Permet de spécifier une durée en jours pour l'utilisation du mécanisme de planification.


Description: Permet de saisir un texte de description pour l'opération, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux objets Opérations.

Il est possible d'effectuer un (un seul) zoom avant sur les objets Opération pour créer automatiquement un nouveau graphe d'opérations les décrivant.


Parallélisme

Afin de nous assurer qu'une l'opération est bien exécutée par plusieurs rôles pour permettre le passage du document à un état donné, nous pouvons installer une Opération parallèle entre ses rôles.



Pour se faire, choisissez l'objet dans la liste des Composants et placez-le entre les rôles concernés. Puis, ajoutez une opération pour chaque rôle à l'intérieur du conteneur.


Propriétés

Général

  • Libellé : Permet de saisir un nom visible pour le rôle
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique)
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir


Description: Permet de saisir un texte de description pour l'opération parallèle, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux objets Opération parallèle.


Groupe de travail

L'option Groupe de travail est disponible dans les propriétés des liens standards et de dérivation et donne la possibilité de choisir un nombre quelconque d'acteurs dans la liste des candidats pour définir un groupe de travail autour du document concerné (tous les acteurs du groupe devront avoir "fait suivre" le document pour que le document passe à l'étape suivante).

Vous pouvez préciser un nombre minimum ainsi qu'un nombre maximum d'acteurs.

L'option Afficher les unités précise que la sélection se fera sur des unités organisationnelles.



Ressource

Les ressources permettent de décrire les modèles abstraits, de processus, procédures, opérations et rôles. Elles représentent des flux d'information entrants ou sortants véhiculés de façon matérielles (documents, formulaires, ...) ou immatérielles (conversations téléphoniques, démarchage, ...) .


Dans l'onglet des Composants, choisissez l'objet et glissez-le dans le graphe de procédure.

Général

  • Libellé : Permet de saisir un nom visible pour l'objet.
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique).
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir.


Description: Permet de saisir un texte de description, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux objets Ressource.

Une ressource peut être émise (produite) par une et une seule procédure ou un et un seul rôle externe, et être utilisée (consultée ou modifiée) par une et seule procédure ou un et un seul rôle externe.


Outil

Les outils servent à décrire les modèles de procédures ou d'opérations. Ils représentent des flux d'information entrants ou sortants en relation avec des applications externes. L'outil le plus souvent utilisé est le connecteur de champ ou d'opération.


Dans l'onglet des Composants, choisissez l'objet et glissez-le dans le graphe de procédure.

Général

  • Libellé : Permet de saisir un nom visible pour l'objet.
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique).
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir.


Description: Permet de saisir un texte de description, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux objets Outil.




Modèle des Opérations

Il n'est pas possible de créer un graphe d'opérations à partir de la fenêtre-projet. Cette création de graphe s'effectue en créant un graph zoom d'une opération existante. Un graphe d'opérations depuis une procédure exprime le fait que le graphe d'opérations décrit en détail le déroulement (des opérations) de la procédure.


On peut distinguer plusieurs types d'opérations qui peuvent se dérouler dans plusieurs types de contexte d'exécution.


Propriétés d'une opération:

Général

  • Libellé : Permet de saisir un nom visible pour l'objet.
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique).
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir.


Description: Permet de saisir un texte de description, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux objets Ressource.


Lors du placement de l'opération sur le graphe avec la souris (drag & drop). L'affectation au rôle s'effectue automatiquement en fonction du placement de l'opération dans la colonne du rôle.

La position de l'opération dans le schéma, dans l'une ou l'autre des colonnes de rôle, détermine le rôle habilité à réaliser l'opération. 


Construction d'un modèle d'opérations

Pour construire un graphe d'opération, sélectionnez un objet opération dans votre graphe de procédures et effectuez un Zoom sur l'objet ([Ctrl]+double-clic) dessus.

Remarquez qu'un nouveau graphe est automatiquement crée dans le panneau du projet (à gauche).


Il est possible ici de créer un nouveau modèle décrivant plus précisément les traitements intervenants dans l'opération en y ajoutant:

  • Opérations
  • Ressources
  • Outils
  • Étiquettes
  • Annotations diverses


Seuls les documents présents dans la procédure parente seront disponibles dans les graphes d'opération.

Seuls des liens standards sont utilisables.



Étiquette

Les étiquettes servent à décrire les modèles d'opérations. Elles sont des indications purement informatives qui aident au travail en collaboration.

Dans l'onglet des Composants, choisissez l'objet et glissez-le dans le graphe de procédure.

Général

  • Libellé : Permet de saisir un nom visible pour l'objet.
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique).
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir.


Description: Permet de saisir un texte de description, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux objets Étiquettes.




Modèle de rôles

En utilisant le concept de Rôle d'ossad, nous voyons quatre groupes de Rôles impliqués dans la réalisation d’un projet OSSAD.

De façon tout à fait classique, ces quatre rôles constitueront un « Groupe de projet », selon les structures les mieux adaptées à la culture et aux pratiques de l’organisation.

Certaines personnes (Acteurs) peuvent intervenir au travers de plusieurs rôles. Par exemple, un Responsable de département pourra être à la fois Utilisateur et Décideur. Dans les organismes de petite taille, il sera fréquent qu’une même personne joue plusieurs de ces Rôles.


Général

  • Libellé : Permet de saisir un nom visible pour le graphe.
  • Nom interne: Attribut Designer_name de l'objet (Ce nom doit être unique).
  • Nom interne calculé automatiquement: Permet de garantir l'unicité des noms interne d'objets en laissant Workey les définir.


Description: Permet de saisir un texte de description, pointer vers un fichier externe contenant le texte de description et entrer un texte d'aide.
Il est aussi possible d'ajouter des Liens logiques aux graphes de Rôles.


Consultez la rubrique des rôles sur la page des fonctions avancées pour plus de détails sur l'utilisation des rôles.


Rôles par défaut (joués sur demande)

Normalement, un rôle doit être explicitement assigné aux intervenants par les gestionnaires des processus. Dans certaines situations, il peut être utile de permettre à tout acteur identifié de jouer le rôle s’il le désire. On peut parler dans ce cas d’une assignation implicite, ou d’un rôle joué “par défaut” ou “à la demande”.

Ce type de rôle est surtout destiné aux opérations de création de nouveaux documents.

Typiquement, le comportement souhaité est le suivant: un utilisateur accède à l’application Workey, constate qu’il peut créer un type de document, bien qu’aucun droit de création ne lui ait encore été accordé. Une fois le document créé, cet utilisateur est automatiquement enregistré comme nouvel acteur pour ce rôle.

L’ensemble des acteurs d’un tel rôle sera donc augmenté à chaque nouvel intervenant.


Construction

Dans la boîte de dialogue des propriétés d’un rôle, il suffit de cocher la case “Assigné par défaut”:
Image:Roledefaut.jpg


Rôle joué par tout le monde ou par n’importe qui?

Il faut noter que le concept présenté ici est différent d’un rôle joué “par tout le monde”, qui consisterait à assigner d’emblée à ce rôle l’ensemble de tous les acteurs identifiés. Dans ce cas, le risque est qu’un nombre important de ces acteurs ne soient assignés inutilement à ce rôle, s’ils ne sont pas intéressés ou bien dans l’impossibilité de le jouer.


Organigrammes

Principe

Ce modèle permet d’exprimer la hiérarchie d’une entreprise et de compléter la notion de rôle.

Dans la suite de ce guide nous parlerons aussi bien d'organigramme que de modèle d’unités organisationnelles.

Ce type de modèle peut être défini pour chaque application ou bien commun à plusieurs applications.

Unité

Le concept central est celui d’ "Unité Organisationnelle", ou "UO" en abrégé, ou encore plus simplement "Unité". Une "UO" est une entité repérée par un nom unique, regroupant un sous-ensemble d’acteurs de l’organisation (des personnes physiques ou des groupes de personnes physiques). Par exemple, on parlera de l’unité "Département Marketing", de l’unité "Equipe ISO 9000", etc. Une unité peut également correspondre à un "poste de travail" ou "fonction dans l’organisme". On parlera ainsi d’unité "Chef de Service" pour désigner l’ensemble des personnes occupant cette fonction au sein d’un organisme. Certaines de ces unités ne comporteront qu’un seul acteur, ou même aucun acteur de manière transitoire (tant que le poste n’a pas été repourvu). Du point de vue du formalisme graphique, une unité est désignée par une boîte rectangulaire aux coins arrondis.

Lien entre unités

Un lien entre deux unités exprime leur dépendance hiérarchique. Il s’agit d’un lien orienté, depuis une unité "A" vers une unité "B", dont la sémantique est: l’unité "B" est sous la "responsabilité" (sous la "dépendance hiérarchique") de l’unité "A". Le graphe "hiérarchique" ou "graphe des Unités Organisationnelles" est le graphe constitué de l’ensemble des unités et des liens définis entre ces unités.

Graphe de type organigramme

Dans Workey, une unité peut être l’origine et la destination d’un nombre indéterminé de liens. Ce point est important, car il permet de s’écarter des contraintes conceptuelles qu’impose un vision purement arborescente de la hiérarchie. Concrètement, il permettra non seulement d’exprimer qu’une unité « A » se décompose en sous-unités "A1", "A2", …, "An", mais également d’exprimer qu’une unité "Ai", si elle est rattachée principalement à une unité "A", peut également être attachée (pour une certaine partie de son activité ) à une unité "B".




Construction d'un organigramme


Double-cliquez sur Organigrammes dans le panneau du Projet à gauche de la fenêtre pour créer un nouveau graphe d'Unités, puis ajustez ses propriétés à vos besoins.

Glissez un composant Unité dans votre graphe, puis ajustez-en les propriétés.

Glissez un composant Poste, puis ajustez-en les propriétés.

Les sections Général, Description et Liens sont disponibles comme pour les autres types d'objets.


Les liens par défaut sont de type Hiérarchique et exprime la dépendance hiérarchique simple entre unités.

Les liens de type Sémantique expriment une dépendance qui ne respecte par l'arborescence hierarchique du groupe. On peut y ajouter un libellé.


Un graphe "hiérarchique" est sans cycle, sinon il n’aurait aucune interprétation concrète.

Un graphe "hiérarchique" n’est pas forcément connexe. Il peut être constitué de plusieurs sous-graphes n’ayant aucune lien entre eux.

Un graphe "hiérarchique" ne doit pas présenter de redondances. En effet, si une dépendance a été exprimée entre "A" et "B", puis entre "B" et "C", une dépendance entre "A" et "C" est redondante et ne doit pas pouvoir être créée.



Matrices Activités/Rôles


Matrice
Représentation montrant les intersections entre les instances de deux concepts (notamment Activité et Rôle) placés l’un en ligne, l’autre en colonne.
Dans la matrice Activité/Rôle, l’intersection définit une Tâche.


Double cliquez sur Matrices A/R dans le panneau des projets pour créer un nouveau graphe.

Général
  • Libellé: Permet de saisir un titre visible dans la génération de la documentation pour la matrice
  • Nom interne: Nom unique de l'objet workey
  • Nom interne calculé automatiquement: Permet de garantir que la contrainte d'unicité des noms internes des objets est respectée.
    Décochez cette option pour personnaliser le nom interne.


Description: Permet de saisir un texte de description

  • Étendue: Permet de lier un fichier externe contenant une description personnalisée
  • Aide: Permet d'entrer un texte d'aide



Exemple de matrice:
Image:Matrice.jpg

La génération et mise à jour de la matrice repose entièrement sur les éléments figurants dans votre modèle abstrait.

Il est donc impératif d'implémenter le modèle abstrait avant de construire la matrice si vous souhaitez générer automatiquement la matrice.


Construction d'une matrice

Deux composants sont disponibles pour ce type de graphe: Rôle et Fonction.


Fonction

L'objet Fonction possède dans ses propriétés une section Implémentation.

Sélectionnez la ou les procédures associées à la fonction courante. Vous pouvez également implémenter les fonctions depuis d'autres graphes où ce type d'objet est présent (comme le modèle abstrait par exemple).


Génération

Image:MatricegenerB.jpg Génération automatique des rôles et fonctions définies dans le modèle abstrait.

Image:Matricegener.jpg

Lorsque la génération de la matrice est demandée, Workey Designer calcule les relations entre les rôles existants dans les procédures et les fonctions définies dans le modèle abstrait.
Image:Matricegenere.jpg

Le résultat présenté met en évidence les fonctions orphelines et les optimisations qu'il faudrait apporter aux modèles.


A noter que si vous avez créé la matrice manuellement, en cliquant sur "Générer la matrice", vous devrez confirmer cette action. En effet, cela effacera tout le contenu de votre matrice pour le remplacer par les informations issues du modèle abstrait.


Mise à jour

Image:MatricemajB.jpg Mise à jour des associations entre les rôles et les fonctions définies dans le modèle abstrait.


Image:Matricemaj.jpg


Lorsque ma mise à jour de la matrice est demandée, Workey Designer recalcule les relations entre les rôles définis dans les procédures et les fonctions du modèle abstrait, puis modifie la répartition des sélections sur chaque ligne. Une boîte de dialogue vous demande confirmation avant d'effectuer la mise à jour car l'ensemble des relations seront supprimées avant d'être recalculées.


Vérification

Image:MatriceverifB.jpg Vérifie que les tâches (fonctions) listées sont bien associées aux rôles définis.


Lorsque la vérification de la matrice est demandée, Workey Designer vérifie les relations entre les rôles et les fonctions et présente une liste d’incohérences entre l'agencement des graphes de procédures et des modèles abstraits ou un message de succès indiquant que les tâches sont correctement associées.


Vérification de cohérence

Lors de la création ou modification de graphes avec Workey, les règles de cohérence propres au langage graphique sont validées en continu. Pour un graphe d'un type donné, il n'est tout simplement pas possible de créer des modèles qui n'auraient aucune interprétation logique. Ainsi pour prendre quelques exemples:

  • on ne peut pas créer de lien vers un rôle,
  • on ne peut pas créer directement de lien vers une opération munie d'une pré-condition, le lien doit être créé vers la pré-condition, la symétrique s'applique pour les post-conditions,
  • on ne peut pas lier entre eux deux documents,
  • etc..

Toutes ces règles sont activées lorsque l'on modélise un graphe.

Un problème fréquent de contrôle de cohérence est celui de la dénomination des objets.
Il est très facile de saisir deux objets différents alors que l'on pense utiliser deux fois le même objet
(il suffit d'oublier un accent ou une majuscule).
Pour éviter ce problème, il est vivement recommandé de sélectionner l'objet parmi la sélection dans la boîte de saisie.


Outre ces règles vérifiées en continu, certaines règles ne peuvent être validées que lors d'une vérification finale avant la génération du Workflow.

Pour plus de détails sur la production automatisée de la documentation, se reporter au chapitre "documentation".


Vérification finale

Outre les vérifications de cohérence qui ont lieu en continu lors de la création du graphe, un certain nombre de vérifications ne peuvent être faites qu'une fois le graphe fini. Pour déclencher ces vérifications, il suffit de choisir l'option "Vérifier" dans le menu Outils :

Image:Verifier.jpg

Si dans notre exemple nous supprimons le lien entre le document Incident<déclaré> et l'opération traiter, notre modèle devient incomplet.


En lançant l'action Vérifier Workflow (menu déroulant), le rapport suivant s'affiche:

Image:Erreurs.jpg

Pour se positionner directement sur l’objet isolé, il suffit de double cliquer sur l'une des cellules du tableau. Workey affichera le graphe contenant l'objet concerné par l'incident de génération.

  • un grand nombre de règles garantissant le fonctionnement logique du Workflow sont vérifiées par cette action,
  • l'exemple présenté est relativement trivial mais la fonction prend toute son importance lorsque l'on traite d'un processus complexe composé de plusieurs procédures ayant des éléments communs,
  • l'action "Vérifier Workflow" est automatiquement lancée au moment de la génération du Workflow.


Consultez la page de Génération de l'application pour de plus amples détails.


Documentation

Le travail avec Workey privilégie les descriptions graphiques. Il est cependant nécessaire de compléter l'information présentée sur les schémas avec des textes décrivant les différents éléments modélisés. C'est pourquoi Workey offre au concepteur la possibilité de saisir une description pour chaque objet.

Un champ de Description est disponible dans les propriétés de chaque objet.


Chaque objet est décrit une seule fois. Si l'on modifie la description d'un objet, la modification est répercutée pour toutes les occurrences de l'objet.


Avec Workey, cette gestion de la documentation est automatique (puisque directement générée depuis le menu Outils).

La génération de documentation peut être lancée depuis n'importe quel type de graphe .


Image:Doc.JPG


Au format HTML (version Online uniquement)

A partir d'une modélisation, il est possible de générer au format HTML (donc accessible via un simple navigateur) la documentation correspondante (graphes cliquables et fiches descriptives).

Le menu Outils / Générer la documentation ou le bouton correspondant permettent de lancer cette génération.


Image:Dochtml.jpg

Il est possible d'ouvrir la documentation immédiatement après la génération dans un navigateur web (doc HTML) ou dans un logiciel de traitement de texte (doc Word).


Au format Word (version Online uniquement)

A partir d'une modélisation, il est possible de générer au format Word la documentation correspondante (graphes cliquables et fiches descriptives).

Le menu Outils / Générer la documentation ou le bouton correspondant permettent de lancer cette génération. Vous avez la possibilité de paramétrer la documentation en sélectionnant les modèles que vous souhaitez faire figurer dans la documentation, le titre, le sommaire, les entêtes et pied de page.


Image:Doc word.JPG

Il est possible d'ouvrir la documentation immédiatement après la génération dans l'application Word (ou tout autre application pouvant ouvrir les fichiers au format .docx)